Τι είναι και τι πρόβλημα λύνει
Το quic-go παρέχει μια στιβαρή, native υλοποίηση του πρωτοκόλλου QUIC (RFC 9000-9002) και HTTP/3 (RFC 9114) στη γλώσσα Go. Επιτρέπει στους developers να ενσωματώσουν δυνατότητες μεταφοράς επόμενης γενιάς στις εφαρμογές τους, παρακάμπτοντας τους περιορισμούς των παραδοσιακών συνδέσεων TCP.
Βασικά χαρακτηριστικά
- Πλήρης κάλυψη RFC: Υποστήριξη για QUIC Version 2, Unreliable Datagram Extension (RFC 9221), QPACK και DPLPMTUD.
- Ενσωμάτωση FIPS: Συμβατότητα με περιβάλλοντα FIPS 140-3 αξιοποιώντας την κρυπτογραφία της standard library της Go.
- Οικοσύστημα και tooling: Υποστήριξη για qlog event logging και συναφή projects όπως το WebTransport και MASQUE.
Σε ποιους απευθύνεται
Απευθύνεται σε Go developers που αναπτύσσουν υπηρεσίες υψηλής απόδοσης, clients ή servers που απαιτούν σύγχρονα πρωτόδικα μεταφοράς δικτύου.